Monthly Archives: February 2018

SCCM randomly fails to join domain and install applications on some computer models

An issue has occured recently in our environment where some computer models, in our case Dell Precision T7600 models, sometimes fail to join the domain during an imaging task sequence, but do not fail the task sequence until they get to the first “Install Applications” step in the sequence. Computers that fail in this way do not have a netsetup.log file where it should be, meaning the computer couldn’t even contact the domain to attempt to join. Further exploration of the log files on the failed client shows the following two clues:

panther\unattendgc\setupact.log
[DJOIN.EXE] Unattended Join: NetJoinDomain failed error code is [1355]
[DJOIN.EXE] Unattended Join: Unable to join; gdwError = 0x54b

ccm\logs\smsts.log
No adapters found in environment. Performing global finalization only.

It turned out in our case that the task sequence was failing to join the domain because the network adapter was too slow to respond after the reboot. I’m not sure if this is due to the T7600’s dual network adapters or some other reason, but so far this is the only model that has shown this behavior in all the years we’ve been using SCCM. In addition, the problem is intermittent and does not always happen – sometimes the machines do succeed in joining AD.

The workaround for this problem is to add a “Join Domain or Workgroup” step in the task sequence (which can be found in the “Add > General” menu in the task sequence editor window) after the “Setup Windows and Configuration Manager” step, and add a delay between the two steps. I added a two minute delay, but that might be overkill. After making this small modification to the task sequence, every single computer completed the second domain join step and therefore finished the rest of the task sequence successfully. Here is what it should look like: Continue reading